Back to overview
Downtime

Storytell experiencing high latency

Feb 18 at 01:42pm EST
Affected services
Storytell Platform

Resolved
Feb 18 at 02:03pm EST

We have identified the cause of this issue and has been resolved.

Created
Feb 18 at 01:42pm EST

We’re having some trouble with Storytell.ai. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.